Blank/Black Screen in Citrix Workspace App with Safari on macOS

Problem

Mac users experiencing black or blank screens in Safari when attempting to access Citrix Workspace apps using workspace.partners.org

Cause 

Appleā€™s latest operating systems, and Safari version 12, create new security procedures that need to be addressed in order to open many Citrix Workspace apps.

Resolution

Configure browser settings for Workspace in Safari, then try again to launch apps.

Requirements

Configure Safari Settings

  1. Open Safari and go to workspace.partners.org  
  2. Open the Safari Menu Bar at the top of your screen (separate from the Safari window)
  3. Select Settings for this Website. This will open a new menu, under the address bar.
  4. In the website's setting window (reads "when visiting this website" at the top), perform the following steps:
    • Uncheck the Enable content blockers box
    • Click over Pop-Up Windows and select Allow

  1. Click anywhere on the page to close the menu.
  2. Refresh the page by clicking on the circular arrow (located on the right of the address bar)
  3. Click Detect Receiver (if it is not already running)

  1. Sign-in with your MGB network credentials (user ID and password) as necessary

If system asks: Do you want to allow this page to open "Citrix Worskpace Launched"? Select Allow

NOTE: If Citrix Workspace asks for an email address or a URL, select Cancel. There is nothing you can type that will be accepted...

  1. Select an application in the Workspace favorites or Applications folder, and the system will download a file ending in .ici
  2. Open your downloads folder,  or click on the download icon in Safari
  3. Select the latest ".ici" file

  1. Afterwards, Citrix Workspace will open the selected application on your Mac.  Please note you can have multiple Citrix apps open, the procedure is the same for each app.


Go to Citrix Workspace home

Go to KB0036191 in the IS Service Desk