TRBL: Haiku/Canto/Rover showing "No Environments Configured"

Symptoms:

User is unable to login to Haiku, Canto, or Rover on their mobile device due to a "No Environments Configured" message.

Cause:

The "No Environments Configured" message indicates that the PRD config isn't installed and Haiku/Canto/Rover doesn't know what "environment" (Epic server) to connect to.

Resolution:

Install the PRD Configuration:

iOS installation instructions:
The PRD Configuration comes prepackaged with the iOS version of the app available via the App Catalog.

Uninstall the Haiku/Canto/Rover app (See https://support.apple.com/en-us/HT207618 for instructions.)
Reboot the device (See https://support.apple.com/en-us/HT201559 for instructions.)
Reinstall the Haiku/Canto/Rover app from the App Catalog.

Android installation instructions:

Confirm that the version of Haiku/Canto/Rover you're using has the 'work-badge' (little briefcase symbol on the icon.)
(If it does not, uninstall Haiku/Canto/Rover, reboot your device, and then redownload Haiku from the App Catalog within the MobileIron Go app.)

Open the Tunnel app

Make sure that the VPN Tunnel is active/enabled.
If the Tunnel won't enable, or generates an error, see VPN/Connectivity Issues.

Open the work-badged (little briefcase symbol) version of Chrome.

Go to https://haiku.partners.org/setup (explicitly typing the https:// part seems to help)

Tap on either the "Haiku>>" "Canto>>" or "Rover>>" button as appropriate.

The indicated app should launch automatically and present you with a License Agreement.

Accept the License Agreement.


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