INFO: SPSS Patching for the Apache Log4j Vulnerability

You must update your SPSS software to version 28 and patch in order to address a critical vulnerability discovered in December 2021.

1. If you are running SPSS version 28 you must apply a patch in order to address a critical vulnerability.

Link to document on installing patch Mac
Link to document on installing patch PC

2. If you are running SPSS version 24 you must uninstall and upgrade to version 28 and then apply a patch in order to address a critical vulnerability.

Links to:

uninstalling version 24

installing version 28

how to apply patch: Mac

how to apply patch: PC

3. To determine the SPSS version you are running, launch SPSS and the version is listed on the launch splash screen

4. Read more about the Apache Log4j critical vulnerability that can lead to potential execution of arbitrary code.

5. Contact rcc@partners.org for technical assistance.
 
* Please spread the word to any of your colleagues who are using SPSS.

SPSS 28 installer instuctions-3.pdf

SPSS update intructions-Mac.docx

SPSS update intructions-PC.docx

UNINSTALLING YOUR EXISTING SPSS.pdf

Go to KB0039144 in the IS Service Desk